Summary


Accounts in 365 are showing as 'in cloud' and not synced with Active directory.



Cause


A number of things could cause this but the usual one is if the accounts were accidentally deleted from 365 and when they were restored the rename as in cloud. An example of this was at Ashford when all their accounts were removed from 365 due to an outage.  



Solution


To resolve this you need to force an update on the account by making a change on it in meta DB.


For example update IAC LastMod and add an additional attribute, in the case with Ashford a '.' was place in extension attribute 1.


Then run a delta import and delta sync on the Meta DB task.


Please note just updating IAC LastMod may not work as FIM won't detect it as an actual change so O365 ignore it, this is why you have to add a value to an attribute, this way FIM will know it has to do an export.