Summary


An account in AD has some proxy addresses set under attribute editor, however these don't show up in 365.




Cause


Proxy addresses will only sync up to 365 if they have the configuration detailed below.




Solution


In attribute editor the proxys need to be configured with a capital SMTP: before the primary email address. Then any other ones need lower case smtp:.


For example:


SMTP:someone@example.com

smtp:anotheraddress@example.com


Proxy's won't sync up if they look like this:


smtp:someone@example.com

smtp:anotheraddress@example.com


The primary requirement is a capital SMTP: prefix with a colon. This will be the primary address of the user in Office 365.